Back to overview
Resolved
PayPal checkout is currently unavailable
Aug 7, 2026 at 5:26pm UTC
Affected services
Website
Resolved
Aug 8, 2026 at 2:31pm UTC
PayPal checkout is now working normally for all customers. You can complete payments with PayPal again.
Affected services
Created
Aug 7, 2026 at 5:26pm UTC
Customers cannot pay with PayPal at checkout. Crypto payments are working normally. We are investigating the issue.
Affected services