Back to overview
Resolved

PayPal payments are failing

Aug 6, 2026 at 8:37am UTC
Affected services
Website

Resolved
Aug 6, 2026 at 11:52am UTC

PayPal payments are now processing normally again. All failed transactions have been resolved.

Updated
Aug 6, 2026 at 8:53am UTC

We applied a fix to restore PayPal payments. We are monitoring transactions to ensure they process correctly.

Created
Aug 6, 2026 at 8:37am UTC

Customers cannot pay using PayPal. We are investigating the issue and working on a fix.